Get in touch
Back
Maintenance

Updating & testing projects server changes

Completed 1 Oct at 02:17pm AWST.

Completed

Server should now be back up! Thank you for your patience!

Posted 1 Oct at 02:17pm AWST.
Updated

Maintenance is still going on, please stand by

Posted 1 Oct at 02:14pm AWST.
Started

Projects Server is being updated and tested and will be going offline for a few minutes.

Posted 1 Oct at 01:56pm AWST.